Message Board
Home Automated Living Forums > General HAL Topics > Technical Assistance » Adding X10 RF using WGL W800USB to HAL2000 v5.2.2

Technical Assistance Questions posted to this conference may be answered by other users and/or HAL Technical Support. You can also contact HAL Technical Support directly.

Reply
 
Thread Tools Display Modes
Old 04-15-2016, 10:40 AM   #1
Adtranz
Junior Member
 
Join Date: May 2012
Location: Southern California
Posts: 5
Default Adding X10 RF using WGL W800USB to HAL2000 v5.2.2

I'm trying to add X10 DS10A 32 bit RF devices to my HAL2000 version 5.2.2 system.
I connected a WGL W800USB receiver and installed the drivers. I added the the W800USB to the system configuration as an Input/Output device. I checked the box to enable W800 inputs and selected com port 4. I have verified that the W800 is sending commands to the computer using the demo software from WGL. I can not find a way to add any X10 device commands from the W800 to HAL2000. HAL2000 is not responding to any 16 bit commands sent from an X10 palm pad controller or 32 bit commands from the X10 DS10A modules.

If HAL2000 can not support X10 32 bit commands from the DS10A, I will replace the W800USB with WGL V572RF32 and translate the 32 bit commands to 16 bit X10 commands that HAL2000 can recognize.

In my test setup, I defined Sensor A01 ON as an input and created a Macro to turn ON L01 when A01 ON is detected. When I use the status monitor, I see the "L01 change to ON" but the lamp controlled by L01 does not turn ON. So HAL is seeing the commands from the Palm Pad X10 RF via the W800, but not sending the command to the X10 module. Also, when I send an L01 ON from the Palm Pad, the status shown for L01 changes but the lamp never turns on. If I use an X10 command console to send the A01 ON command, the Macro runs and turns ON the lamp connected to address L01.

According to WGL, the W800RFUSB device sends raw 16 or 32 bit data directly to the computer via the USB port. I found that when I use a DS10A switch module, which is a 32 bit device, and monitor the data received by HAL, HAL is showing bogus data from the 32 bit module. I believe that HAL has not been programmed to properly parse the 32 bit data which means that I will not be able to use the WGL W800USB device in my system. The bogus data would be constantly confusing HAL. If I am correct in my analysis, HAL should not have the device listed as being compatible in the first place.

I have been asked by WGL to keep them updated on the status of this issue.

What am I missing?
Thanks,
Don

Last edited by Adtranz; 04-17-2016 at 08:39 PM. Reason: Comments regarding WGL W800USB
Adtranz is offline   Reply With Quote
Reply

Bookmarks

Tags
w800usb


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.