Message Board
Home Automated Living Forums > General HAL Topics > Technical Assistance » 6.1.37 breaks backwards compatibility with HALi?

Technical Assistance Questions posted to this conference may be answered by other users and/or HAL Technical Support. You can also contact HAL Technical Support directly.

Reply
 
Thread Tools Display Modes
Old 12-03-2016, 07:26 PM   #1
dtomcat
Advanced Member III
 
Join Date: Aug 2008
Posts: 391
Default 6.1.37 breaks backwards compatibility with HALi?

Installed 6.1.37, now all HALi apps do not work. HALi App "Tell me" gives error:
"System Error &H80040111 (-2147221231). ClassFactory cannot supply requested class"


My SiriHalServer does not run either. I'm in the process of installing Visual Studio back onto the HAL system so I can see what is going on, but wanted to give the warning to others.


I'll post more when I know more. Update with caution for now. (this may be a "my system only" issue)


I'm on Windows 8 and the only thing that runs on my system is HAL, Dropbox, TeamViewer, and in a little bit Visual Studio.


-Rob
__________________
HALpro v7.2.7
Win 7
HAL voices US/UK
HAL DMC
Tell Me v2.7.0
dtomcat is offline   Reply With Quote
Old 12-03-2016, 11:37 PM   #2
dtomcat
Advanced Member III
 
Join Date: Aug 2008
Posts: 391
Default Re: 6.1.37 breaks backwards compatibility with HALi?

Rebuilding my application worked... Appears maybe HALi.ocx changed? Either way, now I have to find my Tell Me code and rebuild that as well :/
__________________
HALpro v7.2.7
Win 7
HAL voices US/UK
HAL DMC
Tell Me v2.7.0
dtomcat is offline   Reply With Quote
Old 12-04-2016, 02:10 PM   #3
dtomcat
Advanced Member III
 
Join Date: Aug 2008
Posts: 391
Default Re: 6.1.37 breaks backwards compatibility with HALi?

Rebuilt Tell Me and works ok again... just had to point it to the new HALi.ocx. program didn't like something changed between old and new?
__________________
HALpro v7.2.7
Win 7
HAL voices US/UK
HAL DMC
Tell Me v2.7.0
dtomcat is offline   Reply With Quote
Old 12-08-2016, 08:53 AM   #4
DadGoneMad
Advanced Member
 
DadGoneMad's Avatar
 
Join Date: Jun 2007
Location: Katy, TX
Posts: 199
Cool Re: 6.1.37 breaks backwards compatibility with HALi?

I don't think it's your system only. I had HALPro 6.1.35 installed and then Microsoft sent out some patch updates. After installation HALPro Internet Server or HAL Server processes would periodically crash only after a minute or so after starting HALPro. It's very strange because it will crash, watchdog will restart the missing processes, run for a few minutes and then crash again. After about an hour or so of watchdog restarting processes it seems like it stops crashing and will run for a few hours then starts the process of crashing all over again. It didn't do this before Microsoft patches were installed. I then saw that 6.1.37 became available and downloaded/installed. After installation it is actually worse and some processes stop, Watchdog restarts them, but then sometimes I don't get the "ear" icon on my taskbar, or worse I get 30 of them showing until I put my mouse over the taskbar and then they all disappear. I have to manually end each HAL process, then restart HALPro again. It will stay up for a few minutes, then (wash, rinse, repeat) some process stop responding. I suspect that Microsoft patched something that is causing this issue. I've opened a ticket with the helpdesk and hope that someone can connect into my system when I go on vacation for the holiday's next week because it's driving me crazy seeing my log file full of processes missing, restarting over and over again. What did Microsoft do that could be causing this because it didn't happen prior to installing the last round of patches they sent out.
DadGoneMad is offline   Reply With Quote
Old 12-08-2016, 04:30 PM   #5
dtomcat
Advanced Member III
 
Join Date: Aug 2008
Posts: 391
Default Re: 6.1.37 breaks backwards compatibility with HALi?

I don't think it's the same problem I am having. My issue is only with HALi apps... my actual HALpro runs fine. Sounds bad for you... maybe try removing that patch? either I haven't gotten that patch or it's something that was corrupted on your PC... Sorry :/
__________________
HALpro v7.2.7
Win 7
HAL voices US/UK
HAL DMC
Tell Me v2.7.0
dtomcat is offline   Reply With Quote
Old 12-12-2016, 05:48 PM   #6
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Default Re: 6.1.37 breaks backwards compatibility with HALi?

Can either of you send Mike or Tyler your error log after a crash to review?
__________________
Tim Shriver
Home Automated Living
TimShriver is offline   Reply With Quote
Old 12-13-2016, 06:04 AM   #7
dtomcat
Advanced Member III
 
Join Date: Aug 2008
Posts: 391
Default Re: 6.1.37 breaks backwards compatibility with HALi?

Tim,
Mine does not through any errors. Only the HALi will through something, but no logs are left in HAL. In the PC's system log I believe I read something that the error is happening when trying to initialize HALi.ocx. Again, once I rebuilt the application with the new OCX supplied, it runs fine. I'm guessing something was changed in the newest OCX that old applications don't know what do. As for Dad's problem... I'm not sure... but his surely must through some errors since HAL itself is crashing.




and as a side note, Tim, Your automatedliving email isn't working... my email attempted to deliver since the day I posted this thread and finally came back as undeliverable.
__________________
HALpro v7.2.7
Win 7
HAL voices US/UK
HAL DMC
Tell Me v2.7.0

Last edited by dtomcat; 12-13-2016 at 06:07 AM.
dtomcat is offline   Reply With Quote
Old 12-13-2016, 07:10 AM   #8
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Default Re: 6.1.37 breaks backwards compatibility with HALi?

Hi Rob,

Yes HALi required a change that caused use to break compatibility. It turns out the QuickInit routine did not initialize some of the areas it was intended to init. So it was a tough call but we thought it was more important that the init areas outlined in the HALi documentation were actually performed.

We have had a couple of reports from customers regarding HAL after a recent windows update. We are trying to identify the common thread between the 3 reports we have, so more data would be great. What we have tried to collect are the typical HAL configuration information along with the hardware and OS details.

Thank you,

Tim
__________________
Tim Shriver
Home Automated Living
TimShriver is offline   Reply With Quote
Old 12-13-2016, 07:23 AM   #9
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Default Re: 6.1.37 breaks backwards compatibility with HALi?

Rob,

Mike suggested that one way to isolate the area of the potential crash would be to disable a number of system settings. If HAL runs fine, then systematically enable those areas again one at a time and restarting HAL to see if one of these settings is causing the issue. Be sure HAL is running fine before trying to enable a setting and be sure to restart HAL after the setting change.

I did this same maneuver months ago and identified a modem issue. Also if you disable the modem be sure to also disable the Telephone ASR under voice recognition...

Tim
__________________
Tim Shriver
Home Automated Living
TimShriver is offline   Reply With Quote
Old 12-20-2016, 08:45 AM   #10
canadauser
Member
 
Join Date: Feb 2007
Location: Port Alberni, BC Canada
Posts: 49
Default Re: 6.1.37 breaks backwards compatibility with HALi?

May not be related, but since it's about 6.1.37 I would toss this in..During upgrade got these errors

Error 1800
File open error: c:\program files\hal\data\macro.dbf
could not open marco.dbf exclusive

followed by

Error 1800
File open error: c:\program files\hal\data\irconfig.dbf
could not open irconfig.dbf exclusive

followed by

Installation successful

HAL started up fine
canadauser is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.