Message Board
Home Automated Living Forums > General HAL Topics > Technical Assistance » Internet Server Can't get email; send notifications

Technical Assistance Questions posted to this conference may be answered by other users and/or HAL Technical Support. You can also contact HAL Technical Support directly.

Reply
 
Thread Tools Display Modes
Old 07-14-2016, 12:30 PM   #1
joesteed
Junior Member
 
Join Date: Dec 2008
Posts: 17
Default Internet Server Can't get email; send notifications

My internet server locks up when trying to download email, giving me a mail start error or a timeout, and then being unusable, consuming lots of CPU. This was new with 6.1.16, persists in 6.1.19. Running Windows 10. Any suggestions? I had a similar problem in one of the v5 versions that was a problem with the mail routines in HAL after some kind of change in SSL. That was fixed at the time. Thanks.
joesteed is offline   Reply With Quote
Old 07-14-2016, 01:01 PM   #2
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Default Re: Internet Server Can't get email; send notifications

Hi Joe,

Can you tell me what kind of email account you are using? Gmail, Yahoo, Hotmail...

Tim
__________________
Tim Shriver
Home Automated Living
TimShriver is offline   Reply With Quote
Old 07-14-2016, 02:08 PM   #3
joesteed
Junior Member
 
Join Date: Dec 2008
Posts: 17
Default Re: Internet Server Can't get email; send notifications

Sorry, Tim. I've tried it with both gmail and comcast.
joesteed is offline   Reply With Quote
Old 07-14-2016, 02:11 PM   #4
joesteed
Junior Member
 
Join Date: Dec 2008
Posts: 17
Default Re: Internet Server Can't get email; send notifications

Tim, I had also submitted this on the website after finding out about your ticket system, and I got the same question there. Do you want me to just keep up that thread or this one? Sorry for the confusion.
joesteed is offline   Reply With Quote
Old 07-14-2016, 02:14 PM   #5
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Default Re: Internet Server Can't get email; send notifications

Hi Joe,

These settings work for sending and receiving email in HAL with a gmail account. You may need to change your gmail account to “allow access to less secure apps”.

https://support.google.com/accounts/.../6010255?hl=en

Incoming mail (POP3): pop.gmail.com
Outgoing mail (SMTP): smtp.gmail.com
Advanced: Incoming Port: 995
Advanced: Requires encrypted connection: checked
Advanced: Outgoing Port: 465
Advanced: Encryption type: SSL
My Server requires authentication: checked
Settings: Use the same settings as my incoming server: checked

Please let me know if this works for you.

Tim
__________________
Tim Shriver
Home Automated Living
TimShriver is offline   Reply With Quote
Old 07-14-2016, 03:18 PM   #6
joesteed
Junior Member
 
Join Date: Dec 2008
Posts: 17
Default Re: Internet Server Can't get email; send notifications

I have been using exactly those settings, including the change to gmail, Tim. Is there something I can do to "start over" without deleting all my programming? Something is clearly not right. I've tried reinstalling, but should I be using different options and manually restoring my files?
joesteed is offline   Reply With Quote
Old 07-14-2016, 08:10 PM   #7
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Default Re: Internet Server Can't get email; send notifications

Hi Joe,

Check the email I just sent you with the settings for my gmail account...

Tim
__________________
Tim Shriver
Home Automated Living
TimShriver is offline   Reply With Quote
Old 09-30-2016, 02:19 PM   #8
tholliday
Junior Member
 
Join Date: Oct 2003
Posts: 16
Default Re: Internet Server Can't get email; send notifications

Has anyone been able to resolve this issue?

I also have the same problem. Tim you and Tyler both sent me some things to try back in July. I had some personal issues to deal with so I did not get around to testing at that time. Today, I finally had a chance to test. The last thing that Tyler asked me to test was installing Hal on another PC. I have tried to download email from a gmail account from another PC with a trial version of Hal installed. I have tried it on two different internet providers and the Hal Internet Server hangs. I can open a telnet session to pop.gmail.com on port 465 on the PC so I know I can communicate to the pop server. I can also use the same POP settings in Outlook and successfully retrieve email using pop. I have verified that the gmail account has POP enable for all mail and that the allow access to less secure apps is enabled. For testing I also disabled the firewall.

I am running Windows 10 and Hal version 6.1.32

Last edited by tholliday; 09-30-2016 at 02:23 PM.
tholliday is offline   Reply With Quote
Old 09-30-2016, 02:25 PM   #9
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Default Re: Internet Server Can't get email; send notifications

I am able to use my gmail account. I am using windows 7. I will try the latest build 6.1.33 later today on a windows 10 system. Do you have anything in your error log? It is possible that the Dart email control we use did not install correctly or an antivirus software may have quarantined the required dll files.

Tim
__________________
Tim Shriver
Home Automated Living

Last edited by TimShriver; 09-30-2016 at 02:27 PM. Reason: typo
TimShriver is offline   Reply With Quote
Old 10-01-2016, 05:54 PM   #10
joesteed
Junior Member
 
Join Date: Dec 2008
Posts: 17
Default Re: Internet Server Can't get email; send notifications

I was able to get outgoing mail working using port 465 and TLS encryption, back when I was having the problem. That works for me, as I want only notifications. But I was never able to get incoming mail working and haven't tried lately, as I only rarely used it. Hope this helps.
joesteed is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.