Message Board
Home Automated Living Forums > General HAL Topics > Technical Assistance » Internet Server Can't get email; send notifications

Technical Assistance Questions posted to this conference may be answered by other users and/or HAL Technical Support. You can also contact HAL Technical Support directly.

Reply
 
Thread Tools Display Modes
Old 11-10-2016, 01:43 PM   #21
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Default Re: Internet Server Can't get email; send notifications

The port you used in your test app is not the same one you used in HAL...
__________________
Tim Shriver
Home Automated Living

Last edited by TimShriver; 11-10-2016 at 01:49 PM.
TimShriver is offline   Reply With Quote
Old 11-11-2016, 09:57 AM   #22
BDD43
Advanced Member III
 
Join Date: Jul 2009
Posts: 308
Default Re: Internet Server Can't get email; send notifications

Yes, my understanding is SSL 465 is depreciated and 587 and TLS is used now...587 with SSL enabled.

It works in my program with those set, but not in HAL...although it did in the past version of HAL. I am currently on the latest and greatest.
BDD43 is offline   Reply With Quote
Old 11-12-2016, 12:12 PM   #23
BDD43
Advanced Member III
 
Join Date: Jul 2009
Posts: 308
Default Re: Internet Server Can't get email; send notifications

It seems it was working on 10/18, but then I see this in the same Error Log. I tried to revert back to 6.1.32 when it was working, but no luck there either.
--

HAL Internet Server V6.1.33 @ 16:17:31 On 11/7/2016
CSecureMail.m_oMailPop_Error: Port: 995, Host: pop.gmail.com, Prot: 0

************************************************** ******************************
HAL Internet Server V6.1.33 @ 16:17:31 On 11/7/2016
CSecureMail.Start
ERROR: Dart.SecurePop.1, 12011, A method is currently blocking the thread. Some PowerTcp methods are not reentrant. For example, if you set a timer and enter the Receive method with a Timeout, and attempt to enter the Receive method again, then this error is generated., 140
BDD43 is offline   Reply With Quote
Old 11-12-2016, 01:23 PM   #24
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Default Re: Internet Server Can't get email; send notifications

There has been no change in that area of the code since Build 5.0.14 back on March 12, 2012. (Added support for secure (SSL/TSL) email POP3 and SMTP connections.)

Tim
__________________
Tim Shriver
Home Automated Living
TimShriver is offline   Reply With Quote
Old 11-12-2016, 01:40 PM   #25
BDD43
Advanced Member III
 
Join Date: Jul 2009
Posts: 308
Default Re: Internet Server Can't get email; send notifications

Interesting. I did a restore back to 10/28, still same issue. All I can say is it was working and now it is not. Not sure what changed on my computer, but I'll go back through and unload anything I can think of that I've done in the last couple of months.
Could you verify that you are running Windows 10, all updates installed up to date? Just want to make sure we are on the same page. I'll also send you my creds in a private message so maybe you can test it on your end. Since my program allowed it to work, I doubt it is a network issue, but could be some other program causing an issue.

Thanks Tim
BDD43 is offline   Reply With Quote
Old 11-12-2016, 01:55 PM   #26
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Default Re: Internet Server Can't get email; send notifications

Got your credentials... I'll try later this evening and let you know. Rather you'll get an email if I'm successful LOL
__________________
Tim Shriver
Home Automated Living
TimShriver is offline   Reply With Quote
Old 11-12-2016, 01:58 PM   #27
BDD43
Advanced Member III
 
Join Date: Jul 2009
Posts: 308
Default Re: Internet Server Can't get email; send notifications

LOL....Thanks! I'll continue to look around on my computer as well.
BDD43 is offline   Reply With Quote
Old 11-12-2016, 09:29 PM   #28
BDD43
Advanced Member III
 
Join Date: Jul 2009
Posts: 308
Default Re: Internet Server Can't get email; send notifications

Never received an email, but not sure if you've had a chance to test either.
BDD43 is offline   Reply With Quote
Old 11-15-2016, 02:52 PM   #29
TimShriver
Administrator
 
TimShriver's Avatar
 
Join Date: Jul 2003
Location: Laurel, MD
Posts: 1,588
Post Re: Internet Server Can't get email; send notifications

Hi Darrin,

You didn't have HAL or Google setup correctly. After I set the port to 465 and adjusted your google account to allow access it worked fine. You should have gotten an email today with the following contents of which has a typo LOL.
Testing 123 Sending an Emial from HA...
11/15/2016 16:40:03 - Execute Action

See this early post in this thread for the instructions you should have followed...
http://www.automatedliving.com/forum...ad.php?p=31581

Attached is a screen shot of the setting change I made in your google account.

Please change your gmail password now for security purposes...

Cheers,

Tim
Attached Images
File Type: jpg GoogleEmail-HAL.jpg (128.8 KB, 2 views)
__________________
Tim Shriver
Home Automated Living

Last edited by TimShriver; 11-15-2016 at 02:55 PM.
TimShriver is offline   Reply With Quote
Old 11-15-2016, 09:14 PM   #30
BDD43
Advanced Member III
 
Join Date: Jul 2009
Posts: 308
Default Re: Internet Server Can't get email; send notifications

Hi Tim,
My 'real' email address did have the correct settings. I changed my HAL to use the test account, set the HAL by your settings, but still same issue. This week I will move HAL to my surface pro. It only has windows 10 and no other programs, so should be a good test.
I will let you know how it goes and thank you for testing that account.
BDD43 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.